Opened 12 years ago

Closed 12 years ago

#22 closed defect (fixed)

missing_value & _FillValue bug fix

Reported by: ros Owned by: ros
Priority: medium Milestone:
Component: cf-checker Version: 1.0
Keywords: missing_value _FillValue Cc:

Description

Section 2.5.1 states that the missing_value and _FillValue attributes must be the same type as the variable to which they are attached. The CF checker throws a python error if these attributes are of type string/char.

The following generates the error, but is actually valid.

char variable(time) ;
    variable:standard_name = "surface_temperature" ;
    variable:_FillValue = "M" ;
    variable:missing_value = "M" ;

Change History (2)

comment:1 Changed 12 years ago by ros

  • Owner changed from cf-checker@… to ros
  • Status changed from new to assigned

Fixed in revision [55]

Caused by the attribute type of missing_value and _FillValue being specified as Numeric (N). Changed this to (D) to indicate it must match the type of the variable to which the attribute is attached.

The separate type checks run in chk_FillValue() have been removed as they are now covered by the changes made to chkAttribute() as a result of the introduction of the attribute type (D).

The attribute types table in Appendix A of the CF Conventions Document will need to be updated accordingly. A new ticket proposing changes to the Conventions/Conformance? document will be raised.

comment:2 Changed 12 years ago by ros

  • Resolution set to fixed
  • Status changed from assigned to closed

CF Conventions Document updated as detailed in ticket #23

Note: See TracTickets for help on using tickets.